View Full Version : so frustrating!

10-15-2012, 06:51 PM
I have been trying for the past few hours to pay for a PPA membership, but can't.

I believe it has to do with my "last name." I go by "John Nettles, Jr." and there are typically no spaces to put "JR" so I tag it onto my last name on the same line. When I try to fill out all the information and submit it I get an Error that I have entered invalid characters (it would be nice if this error was more detailed seeing as I have been typing and clicking boxes for an hour....)

I tried to change my name by going into the settings and clicking edit, but it will only allow me to change my email address, not my name or anything else about me.

There isn't even a "contact us" area to get quick and easy help.

I even tried to log out so I could use ANOTHER email address and start this all over again, but when I clicked "log out" I got an error that "this page no longer exists or was moved from the PPA website" and I can't even log out!

Please, someone, help me figure this out.
Thank you

10-15-2012, 06:56 PM

They should be able to help you here: 404-522-8600 | 800-786-6277

I hope everything gets cleared up for you.

10-16-2012, 04:53 PM
John, just leave off the Jr. when you register, and when you get the your confirmation, shoot an email back to csc@ppa.com and they can add the suffix. There is a field for it in the data, and I'm not sure why it isn't visible on the front end to you. I'm posting a message to IT to see if that can be remedied. Sorry for the frustration. 800-786-6277 will get you straight through to Customer Service if you would like to join over the phone. Hope this helps.

10-24-2012, 10:29 PM
Adding to the Frustration thread. I've been trying for ten minutes to simply update my telephone contact information. I edit the record, click save, and the record reverts to the old number. I'm sure that this is a glitch, but there's also no "Help" or "Feedback" link to report this. Anyone have a clue as to how to update my phone number? Editing my profile does not work.

11-15-2012, 06:31 PM
I just discovered that my username has an underscore in it now instead of a space so that's been screwing up my logging in ltely. And, of course, there's no way to change your name, just password and some other info. I hope they fix that soon, too.